2016-04-12 11:34 GMT+02:00 Paul Gofman gofmanp@gmail.com:
static HRESULT d3dx9_apply_state(struct ID3DXEffectImpl *effect, struct d3dx_pass *pass,
struct d3dx_state *state, int parent_index)
struct d3dx_state *state, unsigned int parent_index);
+HRESULT d3dx_set_shader_const_fxlc(struct ID3DXEffectImpl *effect, struct d3dx_pass *pass,
struct d3dx_parameter *param, BOOL vs)
Nitpick, the _fxlc suffix doesn't seem correct at this point I think. Just call it d3dx_effect_set_shader_constants() or something similar? The function can probably be static too.
+static HRESULT set_shader_constants_device(struct IDirect3DDevice9 *device, struct d3dx_regstore *rs,
D3DXPARAMETER_TYPE type, enum pres_reg_tables table)
+{
- unsigned int start, n;
Maybe call it "count" instead of "n"? It's up to you though.