From: Dmitry Timoshkov dmitry@baikal.ru
Fixes: https://bugs.winehq.org/show_bug.cgi?id=44914
Signed-off-by: Alistair Leslie-Hughes leslie_alistair@hotmail.com --- dlls/winex11.drv/mouse.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dlls/winex11.drv/mouse.c b/dlls/winex11.drv/mouse.c index c3ec916..a7e2515 100644 --- a/dlls/winex11.drv/mouse.c +++ b/dlls/winex11.drv/mouse.c @@ -834,8 +834,8 @@ static const struct system_cursors user32_cursors[] = { OCR_ICON, "icon" }, { OCR_SIZENWSE, "top_left_corner" }, { OCR_SIZENESW, "top_right_corner" }, - { OCR_SIZEWE, "left_side" }, - { OCR_SIZENS, "top_side" }, + { OCR_SIZEWE, "h_double_arrow" }, + { OCR_SIZENS, "v_double_arrow" }, { OCR_NO, "not-allowed" }, { OCR_HAND, "hand2" }, { OCR_APPSTARTING, "left_ptr_watch" },
Alistair Leslie-Hughes leslie_alistair@hotmail.com writes:
From: Dmitry Timoshkov dmitry@baikal.ru
Fixes: https://bugs.winehq.org/show_bug.cgi?id=44914
Signed-off-by: Alistair Leslie-Hughes leslie_alistair@hotmail.com
dlls/winex11.drv/mouse.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
I don't think there's such a thing as the "correct" name. I worry that this will just be moving the problem around. We should probably add support for checking multiple names.
Alexandre Julliard julliard@winehq.org wrote:
I don't think there's such a thing as the "correct" name. I worry that this will just be moving the problem around. We should probably add support for checking multiple names.
For WE/NS cursors when bi-directional arrows are expected "left_side" and "top_side" names don't seem to be an appropriate choice in any case, "h_double_arrow" and "v_double_arrow" appear to be more correct.
Dmitry Timoshkov dmitry@baikal.ru writes:
Alexandre Julliard julliard@winehq.org wrote:
I don't think there's such a thing as the "correct" name. I worry that this will just be moving the problem around. We should probably add support for checking multiple names.
For WE/NS cursors when bi-directional arrows are expected "left_side" and "top_side" names don't seem to be an appropriate choice in any case, "h_double_arrow" and "v_double_arrow" appear to be more correct.
I'm not sure how you'd determine what's more correct. left_side and top_side at least are in cursorfont.h, so by that metric they are more standard. Checking a random sampling of existing themes there doesn't seem to be a clear winner.