Hi,
On 03/07/15 12:13, YongHao Hu wrote:
There's no need to check the stream state here, it will be done by stream reading functions.
I think that the implementation will be more readable if you just return on error here. The if(!ios_base_fail(...)) line can be changed to: if(ios_base_fail(&base->base)) return this; You don't need to set failbit in this case because it's already set by basic_istream_char_read_float. The same applies to some other ios_base_fail() checks.
Thanks, Piotr
Good point. I had sent a new patch to wine-patch. Thank you very much for your comment. : )
On 2015年03月09日 18:23, Piotr Caban wrote: