Vitaliy Margolen wrote:
titon barua wrote:
- write(*(This->fd), &event, sizeof(event));
- if (write(*(This->fd), &event, sizeof(event)) == -1) perror ( NULL );
What's the point of your patch? What part of the comment isn't clear to you?
GCC is complaining about the ignored return value.
As Alexandre implied in http://www.winehq.org/pipermail/wine-devel/2009-January/071769.html one should not fix these warnings casually. A real fix probably involves actually handing the error rather than printing a warning.
The last thing we need is an army of people papering over compiler warnings. - Dan
Damjan wrote:
ssize_t ignored; ... ignored = write(*(This->fd), &event, sizeof(event));
You could make the ignored variable static, maybe even global.
Please don't. We don't want to ignore the errors, we want to handle them. The changes you're proposing are harmful to readability. Better to ignore the compiler warnings than to paper them over like that.
On Mon, Jan 5, 2009 at 4:42 PM, Dan Kegel dank@kegel.com wrote:
Damjan wrote:
ssize_t ignored; ... ignored = write(*(This->fd), &event, sizeof(event));
You could make the ignored variable static, maybe even global.
Please don't. We don't want to ignore the errors, we want to handle them. The changes you're proposing are harmful to readability. Better to ignore the compiler warnings than to paper them over like that.
I agree in general, but you probably missed the comment above the write(): /* we don't care about the success or failure of this call */
Damjan