James Hawkins truiken@gmail.com writes:
+/******************************************************************************
- RtlCopyAcl [NTDLL.@]
- */
+BOOLEAN WINAPI RtlCopyAcl(DWORD nDestinationAclLength, PACL pDestinationAcl, PACL pSourceAcl)
I don't see any RtlCopyAcl in ntdll. Where does this come from?
On 17 Jun 2005 11:56:32 +0200, Alexandre Julliard julliard@winehq.org wrote:
James Hawkins truiken@gmail.com writes:
+/******************************************************************************
- RtlCopyAcl [NTDLL.@]
- */
+BOOLEAN WINAPI RtlCopyAcl(DWORD nDestinationAclLength, PACL pDestinationAcl, PACL pSourceAcl)
I don't see any RtlCopyAcl in ntdll. Where does this come from?
There isn't an RtlCopyAcl in ntdll, but it simplifies the code a bit and can be useful in other places. For one I should've taken out the [NTDLL.@] because we don't export it, but should the function be named something else?
James Hawkins truiken@gmail.com writes:
There isn't an RtlCopyAcl in ntdll, but it simplifies the code a bit and can be useful in other places. For one I should've taken out the [NTDLL.@] because we don't export it, but should the function be named something else?
Yes, it should be named something like copy_acl to make it clear it's an internal function, and it should definitely not be declared in an exported header.