On Monday 12 January 2009 18:19:54 Jacek Caban wrote:
+static void HTTP_ReceiveRequest(WININETHTTPREQW *req) +{
- INTERNET_ASYNC_RESULT iar;
- BYTE buffer[4048];
I think HTTP_ReceiveRequestData would be a better name for this function. And I guess this is also a good opportunity to round that buffer size up to the nearest power of two.
-Hans
Hans Leidekker wrote:
On Monday 12 January 2009 18:19:54 Jacek Caban wrote:
+static void HTTP_ReceiveRequest(WININETHTTPREQW *req) +{
- INTERNET_ASYNC_RESULT iar;
- BYTE buffer[4048];
I think HTTP_ReceiveRequestData would be a better name for this function.
Right, I've resent a new patch.
And I guess this is also a good opportunity to round that buffer size up to the nearest power of two.
It won't change much, we don't wait for whole data, so, in my tests, recv returns after reading 1448 bytes. It's similar to Windows, where I get 1460 bytes.
Thanks, Jacek
Jacek Caban wrote:
Hans Leidekker wrote:
And I guess this is also a good opportunity to round that buffer size up to the nearest power of two.
It won't change much, we don't wait for whole data, so, in my tests, recv returns after reading 1448 bytes. It's similar to Windows, where I get 1460 bytes.
Sorry, I should go to sleep, I've missed the part about power of two. I will send another patch.
Thanks, Jacek