Hi Alexandre,
On 10/04/16 22:49, GOUJON Alexandre wrote:
Please change name of fnvPrime variable to something like fnv_prime. Also you will need to initialize it using #ifdef, something like this should work: #ifdef _WIN64 MSVCRT_size_t hash = ... #else MSVCRT_size_t hash = ... #endif
This will also cause compilation warning during 32-bit compilation.
And this.
Thanks, Piotr
Piotr Caban piotr.caban@gmail.com wrote:
This one can't cause a compilation warning since it's conditionally compiled.
On 10/05/16 10:57, Dmitry Timoshkov wrote:
I've thought about this one: if(sizeof(void*) == sizeof(int)) ok(hash1 == 0x40c5b8c, "hash = %p\n", (void*)hash1); + else + ok(hash1 == 0xaf63bc4c29620a60, "hash = %p\n", (void*)hash1);
On 10/05/2016 10:56 AM, Piotr Caban wrote:
Done.
You used both #ifdef _WIN64 and if(sizeof(void*) == sizeof(int)) in the test but now I see the difference. I just sent another version.
Thanks for the feedback!