Bernhard Loos bernhardloos@googlemail.com wrote:
- int debug_childs:1; /* also debug all child processes */
'debug_children' would be a better name.
On Fri, Oct 07, 2011 at 11:44:24AM +0900, Dmitry Timoshkov wrote:
Bernhard Loos bernhardloos@googlemail.com wrote:
- int debug_childs:1; /* also debug all child processes */
'debug_children' would be a better name.
also unsigned int foo:1; please. (int foo:1 works, but is semidefined only ;)
Ciao, Marcus
On Fri, Oct 07, 2011 at 08:32:27PM +0200, Marcus Meissner wrote:
On Fri, Oct 07, 2011 at 11:44:24AM +0900, Dmitry Timoshkov wrote:
Bernhard Loos bernhardloos@googlemail.com wrote:
- int debug_childs:1; /* also debug all child processes */
'debug_children' would be a better name.
also unsigned int foo:1; please. (int foo:1 works, but is semidefined only ;)
Why the bitfield anyway? Unless you are allocating a lot of copies of the structure it is likely to generate more code than the saved memory.
David
On Sat, Oct 8, 2011 at 10:05 AM, David Laight david@l8s.co.uk wrote:
On Fri, Oct 07, 2011 at 08:32:27PM +0200, Marcus Meissner wrote:
On Fri, Oct 07, 2011 at 11:44:24AM +0900, Dmitry Timoshkov wrote:
Bernhard Loos bernhardloos@googlemail.com wrote:
- int debug_childs:1; /* also debug all child processes */
'debug_children' would be a better name.
also unsigned int foo:1; please. (int foo:1 works, but is semidefined only ;)
Why the bitfield anyway? Unless you are allocating a lot of copies of the structure it is likely to generate more code than the saved memory.
Actually, the generated code is pretty much exactly the same size or even smaller for one function. Also, it makes it clear that this is a boolean flag.
David
-- David Laight: david@l8s.co.uk