+#define RTL_UNLOAD_EVENT_TRACE_NUMBER 64
+RTL_UNLOAD_EVENT_TRACE RtlpUnloadEventTrace[RTL_UNLOAD_EVENT_TRACE_NUMBER];
Why did you add these? If you don't need them for the stub implementation, I recommend submitting a revised patch without them.
-Alex
Also, your patch correctly defines PRTL_UNLOAD_EVENT_TRACE, but in the implementation please use RTL_UNLOAD_EVENT_TRACE * instead. See https://wiki.winehq.org/Submitting_Patches#Code_guidelines
-Alex