Sets up these definitions needed for future patches
Signed-off-by: Joshua Ashton joshua@froggi.es --- dlls/winevulkan/vulkan_private.h | 12 ++++++++++++ 1 file changed, 12 insertions(+)
diff --git a/dlls/winevulkan/vulkan_private.h b/dlls/winevulkan/vulkan_private.h index 17072d2341..88233daced 100644 --- a/dlls/winevulkan/vulkan_private.h +++ b/dlls/winevulkan/vulkan_private.h @@ -34,6 +34,18 @@
#include "vulkan_thunks.h"
+#if defined(__GNUC__) || defined(__clang__) +#include <alloca.h> +#define WINEVULKAN_FORCEINLINE __attribute__((always_inline)) inline +#define WINEVULKAN_ALLOCA(x) alloca(x) +#elif defined(_MSC_VER) +#include <malloc.h> +#define WINEVULKAN_FORCEINLINE __forceinline +#define WINEVULKAN_ALLOCA(x) _alloca(x) +#else +#error Unsupported platform for forceinline/alloca +#endif + /* Magic value defined by Vulkan ICD / Loader spec */ #define VULKAN_ICD_MAGIC_VALUE 0x01CDC0DE
Hi,
While running your changed tests, I think I found new failures. Being a bot and all I'm not very good at pattern recognition, so I might be wrong, but could you please double-check?
Full results can be found at: https://testbot.winehq.org/JobDetails.pl?Key=66437
Your paranoid android.
=== debiant (build log) ===
error: patch failed: dlls/winevulkan/vulkan_private.h:34 Task: Patch failed to apply
=== debiant (build log) ===
error: patch failed: dlls/winevulkan/vulkan_private.h:34 Task: Patch failed to apply
Joshua,
It looks like Marvin's getting a bit confused by your patches, here's what it's trying (and failing) to apply: https://testbot.winehq.org/GetFile.pl?JobKey=66437&StepKey=1
It looks like your email it tried to merge your plaintext email body with the attachment, might be worth seeing what happens if you don't attach the .patch files explicitly.a
The actual .patch file which you've attached applies correctly to my local tree.
On 3/5/20 9:03 AM, Joshua Ashton wrote:
Sets up these definitions needed for future patches
Signed-off-by: Joshua Ashton joshua@froggi.es
dlls/winevulkan/vulkan_private.h | 12 ++++++++++++ 1 file changed, 12 insertions(+)
diff --git a/dlls/winevulkan/vulkan_private.h b/dlls/winevulkan/vulkan_private.h index 17072d2341..88233daced 100644 --- a/dlls/winevulkan/vulkan_private.h +++ b/dlls/winevulkan/vulkan_private.h @@ -34,6 +34,18 @@
#include "vulkan_thunks.h"
+#if defined(__GNUC__) || defined(__clang__) +#include <alloca.h> +#define WINEVULKAN_FORCEINLINE __attribute__((always_inline)) inline
Rather than creating a new WINEVULKAN_FORCEINLINE definition here, I think you should just be able to use the existing FORCEINLINE definition which is supplied by winnt.h
Thanks,
Liam Middlebrook
+#define WINEVULKAN_ALLOCA(x) alloca(x) +#elif defined(_MSC_VER) +#include <malloc.h> +#define WINEVULKAN_FORCEINLINE __forceinline +#define WINEVULKAN_ALLOCA(x) _alloca(x) +#else +#error Unsupported platform for forceinline/alloca +#endif
- /* Magic value defined by Vulkan ICD / Loader spec */ #define VULKAN_ICD_MAGIC_VALUE 0x01CDC0DE
----------------------------------------------------------------------------------- This email message is for the sole use of the intended recipient(s) and may contain confidential information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply email and destroy all copies of the original message. -----------------------------------------------------------------------------------