"Paul TBBle Hampson" Paul.Hampson@Pobox.com wrote:
/* Make sure we haven't already got an entry for this due to substitution */
duplicate = FALSE;
LIST_FOR_EACH_ENTRY(system_font_link, &system_links, SYSTEM_LINKS, entry)
{
if(!strcmpW(system_font_link->font_name, font_link->font_name))
{
duplicate = TRUE;
break;
}
}
Font name comparison should be case insensitive. If there are other places that do that they should be fixed.
if(duplicate)
{
TRACE("\tDuplicate font_link entry, ignoring\n");
HeapFree(GetProcessHeap(), 0, font_link);
continue;
}
A '\t' at the start of a trace message doesn't improve readability.
On Wed, Apr 15, 2009 at 01:59:50PM +0900, Dmitry Timoshkov wrote:
"Paul TBBle Hampson" Paul.Hampson@Pobox.com wrote:
/* Make sure we haven't already got an entry for this due to substitution */
duplicate = FALSE;
LIST_FOR_EACH_ENTRY(system_font_link, &system_links, SYSTEM_LINKS, entry)
{
if(!strcmpW(system_font_link->font_name, font_link->font_name))
{
duplicate = TRUE;
break;
}
}
Font name comparison should be case insensitive. If there are other places that do that they should be fixed.
I'll fix that. I might have miscopied it, but I suspect I didn't, so I'll add a patch to the series to fix the other instances.
if(duplicate)
{
TRACE("\tDuplicate font_link entry, ignoring\n");
HeapFree(GetProcessHeap(), 0, font_link);
continue;
}
A '\t' at the start of a trace message doesn't improve readability.
It's consistent with the other path for this code, which is a tab-indented listing of fonts being added to the entry.
If needs be I could rearrange the messages to not do so, but again this would be a different patch.