Signed-off-by: Andrey Gusev andrey.goosev@gmail.com --- libs/vkd3d/command.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libs/vkd3d/command.c b/libs/vkd3d/command.c index 1db624e..9912002 100644 --- a/libs/vkd3d/command.c +++ b/libs/vkd3d/command.c @@ -2746,7 +2746,7 @@ static void d3d12_command_list_update_descriptor_table(struct d3d12_command_list descriptor = base_descriptor + range->offset;
descriptor_count = range->descriptor_count; - if ((unbounded = descriptor_count == UINT_MAX)) + if ((unbounded = descriptor_count) == UINT_MAX) { descriptor_count = vkd3d_gpu_descriptor_allocator_range_size_from_descriptor( &list->device->gpu_descriptor_allocator, descriptor);
On Thu, Dec 16, 2021 at 5:30 AM Andrey Gusev andrey.goosev@gmail.com wrote:
if ((unbounded = descriptor_count == UINT_MAX))
if ((unbounded = descriptor_count) == UINT_MAX)
'unbounded' is a bool, so we do in fact want to assign it the value of descriptor_count == UINT_MAX, though for clarity it could use extra parentheses around the condition.