On 11 April 2013 11:40, Stefan Dösinger stefan@codeweavers.com wrote:
for (i = 0; i < 6; ++i)
{
This could probably do with an appropriate constant.
+enum shader_tex_types +{
- shader_tex_2d = 0,
- shader_tex_3d = 1,
- shader_tex_cube = 2,
+};
Please use uppercase for enum elements. Some "wined3d" prefixes probably wouldn't hurt either, although I guess it doesn't matter so much for things that are only used internally.