Eric Pouech eric.pouech@orange.fr writes:
- if ((cpl.console = console_input_get( req->handle, FILE_READ_PROPERTIES )))
- {
data_size_t sz;
reply->num_processes = sz = cpl.console->num_proc;
if ((sz *= sizeof(process_id_t)) <= get_reply_max_size())
That's much harder to read than necessary. Please set sz in a more conventional manner.
+/* Get console's process list */ +@REQ(get_console_process_list)
- obj_handle_t handle; /* handle to console input (0 for current process console) */
+@REPLY
- int num_processes; /* number of processes attached to this console */
- VARARG(pidlist,ints); /* process list */
Please add a proper tracing function for process ids, they would be hard to recognize as ints.