2005-05-19 Kouji Sasaki taro-x@justsystem.co.jp
Changelog:
* dlls/comctl32/listview.c Corrected the priority of operators for LISTVIEW_GetNextItem function.
--- dlls/comctl32/listview.c 2005-04-14 22:58:24.000000000 +0900 +++ dlls/comctl32/listview.c 2005-05-16 11:29:08.003084512 +0900 @@ -5665,7 +5665,7 @@ * so it's worth optimizing */ if (uFlags & LVNI_FOCUSED) {
- if (!(LISTVIEW_GetItemState(infoPtr, infoPtr->nFocusedItem, uMask) & uMask) == uMask) return -1;
- if (!((LISTVIEW_GetItemState(infoPtr, infoPtr->nFocusedItem, uMask) & uMask) == uMask)) return -1;
Wouldn't it be more readable and less confusing in the below form?
if ((LISTVIEW_GetItemState(infoPtr, infoPtr->nFocusedItem, uMask) & uMask) != uMask) return -1;
-- Dmitry.
I will send the modified patch, as changing the patch accordingly will make the source much easier to read.
Changelog:
* dlls/comctl32/listview.c
Corrected the priority of operators for LISTVIEW_GetNextItem function.
-- Justsystem Corporation taro-x@justsystem.co.jp