Alistair Leslie-Hughes leslie_alistair@hotmail.com writes:
diff --git a/dlls/dpnet/Makefile.in b/dlls/dpnet/Makefile.in index 541e104..70ccef0 100644 --- a/dlls/dpnet/Makefile.in +++ b/dlls/dpnet/Makefile.in @@ -7,6 +7,7 @@ C_SRCS = \ client.c \ dpnet_main.c \ lobbiedapp.c \
- lobbyclient.c \ peer.c \ server.c \ threadpool.c
Please merge that code into some existing files, we don't need so many new files.
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Hi Alistair,
Since you have to resend it anyway, I'll point out some things you missed:
Am 2014-05-16 11:55, schrieb Alistair Leslie-Hughes:
+extern HRESULT DPNET_CreateDirectPlay8LobbyClient(IClassFactory *iface, IUnknown *pUnkOuter, REFIID riid, void **ppobj) DECLSPEC_HIDDEN;
ppobj, pUnkOuter. I guess "riid" qualifies as hungarian notation as well, "iid" would be a better name.
+static HRESULT WINAPI lobbyclient_GetConnectionSettings(IDirectPlay8LobbyClient *iface, DPNHANDLE connection, DPL_CONNECTION_SETTINGS *sessioninfo, DWORD *infosize, DWORD flags) +{
- IDirectPlay8LobbyClientImpl *This = impl_from_IDirectPlay8LobbyClient(iface);
- FIXME("(%p)->(%d %p %p %x)\n", This, connection, sessioninfo, infosize, flags);
DPNHANDLE is a DWORD, so you should use %u. This affects the other functions as well.
You may want to use 0x%0x, or %#x instead of %x to make it obvious that a value in the logs is a hex value. This is purely a matter of taste and I'll leave it up to you - just pointing out the options.
+HRESULT DPNET_CreateDirectPlay8LobbyClient(IClassFactory *iface, IUnknown *pUnkOuter, REFIID riid, void **obj)
Same as above.
- client = HeapAlloc(GetProcessHeap(), HEAP_ZERO_MEMORY, sizeof(IDirectPlay8LobbyClientImpl));
- if (!client) {
*obj = NULL;
return E_OUTOFMEMORY;
- }
} placement.
Stefan
On 16 May 2014 14:22, Stefan Dösinger stefandoesinger@gmail.com wrote:
- client = HeapAlloc(GetProcessHeap(), HEAP_ZERO_MEMORY, sizeof(IDirectPlay8LobbyClientImpl));
- if (!client) {
*obj = NULL;
return E_OUTOFMEMORY;
- }
} placement.
While we're handing out style hints, I think "sizeof(*client)" is generally nicer for this kind of thing.
Hello Stefan,
On 05/16/2014 02:22 PM, Stefan Dösinger wrote:
Since you have to resend it anyway, I'll point out some things you missed:
Am 2014-05-16 11:55, schrieb Alistair Leslie-Hughes:
+extern HRESULT DPNET_CreateDirectPlay8LobbyClient(IClassFactory *iface, IUnknown *pUnkOuter, REFIID riid, void **ppobj) DECLSPEC_HIDDEN;
ppobj, pUnkOuter. I guess "riid" qualifies as hungarian notation as well, "iid" would be a better name.
riid is the documented name on http://wiki.winehq.org/COMGuideline Some of the variables are "well established" now even though they might have had a hungarian notation background.
bye michael
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Am 2014-05-16 14:34, schrieb Michael Stefaniuc:
riid is the documented name on http://wiki.winehq.org/COMGuideline Some of the variables are "well established" now even though they might have had a hungarian notation background.
Ok. While I am aware of the COM guide I didn't notice the "riid" naming. Never mind this name then.