On 16 October 2014 17:07, Stefan Dösinger stefan@codeweavers.com wrote:
diff --git a/dlls/d3d9/tests/d3d9ex.c b/dlls/d3d9/tests/d3d9ex.c index 11fe091..34b967a 100644 --- a/dlls/d3d9/tests/d3d9ex.c +++ b/dlls/d3d9/tests/d3d9ex.c @@ -37,6 +37,7 @@ struct device_desc unsigned int width; unsigned int height; BOOL windowed;
- DWORD behavior_flags;
};
I don't like this much, I'd probably prefer "windowed" and "behavior_flags" to be merged into a single flags field and then have flags along the lines of e.g. CREATE_DEVICE_FULLSCREEN, CREATE_DEVICE_NOWINDOWCHANGES, CREATE_DEVICE_SWVP_ONLY, etc.
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Am 2014-10-17 08:46, schrieb Henri Verbeet:
I don't like this much, I'd probably prefer "windowed" and "behavior_flags" to be merged into a single flags field and then have flags along the lines of e.g. CREATE_DEVICE_FULLSCREEN, CREATE_DEVICE_NOWINDOWCHANGES, CREATE_DEVICE_SWVP_ONLY, etc.
The negative side effect of that is that tests that test D3DCREATE_NOWINDOWCHANGES don't spell out the name D3DCREATE_NOWINDOWCHANGES, making a search if we have any tests for that more difficult. I'll send patches with this change, pick whichever you like better.