First just a quick update on my work converting wined3d from using glx to using wgl. I have some (i.e. one :( ) basic dx9 demos working, and am trying to iron out a bug I can't track down easily since it is crashing in the GL library (in glDrawArrays) and I don't get a backtrace. I know the spot it is crashing so I just have to find out why. My current guess is that I have some GL context stuff fubar'd somewhere.
Anyways, now on to my real reason for this post. Currently there are a _lot_ of #defines for wgl extensions in dll/opengl32/wgl_ext.c. These are all necessary of course, but since they are also becoming necessary for wined3d to use (due to my glx->wgl port) I though it might be better if we included a real wglext.h into include/ and use that. SGI maintains a version of this at http://oss.sgi.com/projects/ogl-sample/ABI/wglext.h
The advantage of using this is that we get all WGL extensions' function definitions and constants, and SGI maintains it for us :)
So I'd like to propose a patch (which I have done already if there are no objections): 1) add wglext.h from SGI's site to include/ 2) change dlls/opengl32/wgl_ext.c to include wglext.h and remove redundant #defines 3) rename (CVS = ich!) dlls/opengl32/wgl_ext.h to dlls/opengl32/wgl_private.h since that is really what it is and the current name is too close to the official one IMO. This file is only used by wgl.c and wgl_ext.c anyways, so name is not too important other than esthetics.
Comments appreciated!