On 2 October 2015 at 14:54, Matteo Bruni mbruni@codeweavers.com wrote:
+static void PRINTF_ATTR(4, 5) declare_in_varying(const struct wined3d_gl_info *gl_info,
struct wined3d_string_buffer *buffer, BOOL flat, const char *format, ...)
It's not a huge issue, but generally speaking things are more readable on the caller side when you use a flag or enum instead of a BOOL. I.e., "declare_in_varying(..., TRUE, ...);" vs. e.g. "declare_in_varying(..., WINED3D_GLSL_INTERPOLATE_FLAT, ...);".