Lucas Zawacki lfzawacki@gmail.com writes:
@@ -57,6 +57,34 @@ BOOL WINAPI DllMain(HINSTANCE hdll, DWORD reason, LPVOID reserved) return TRUE; }
+static void get_joystick_name(struct Joystick *joy) +{
- /* Base product guids as Wine defines them in DirectInput */
- /* 9e573ed9-7734-11d2-8d4a-23903fb6bdf7 */
- static const GUID linux_guid = { 0x9e573ed9, 0x7734, 0x11d2, {0x8d, 0x4a, 0x23, 0x90, 0x3f, 0xb6, 0xbd, 0xf7} };
- /* 9e573eda-7734-11d2-8d4a-23903fb6bdf7 */
- static const GUID linuxinput_guid = { 0x9e573eda, 0x7734, 0x11d2, {0x8d, 0x4a, 0x23, 0x90, 0x3f, 0xb6, 0xbd, 0xf7} };
- static REFGUID wine_guids[] = { &linux_guid, &linuxinput_guid };
- static const WCHAR wine_device_names[2][9] = { {'(','j','s',')','\0'}, {'(','e','v','e','n','t',')','\0'} };
I think dinput should be appending that to the returned name, joy.cpl shouldn't have to know about the specific naming scheme of the driver.
I think dinput should be appending that to the returned name, joy.cpl shouldn't have to know about the specific naming scheme of the driver.
Do you mean change the reported name directly at device creation time? I could do that and I guess that would be mostly harmless, do other people working on dinput have something against this?