Marcus Meissner marcus@jet.franken.de writes:
That was the time that I spotted that the #defines for the IP_* stuff _differs_ between winsock and winsock2. So I had to split up the IPPROTO_IP handling. I tried to keep code duplication to a minimum.
I am not sure whether the forwarders are good style.
They are not IMHO. I'd suggest writing a ws1-to-ws2 conversion function instead, and use it (by duplicating its code) both for the 16-bit functions in ws2_32 and for the version 1 functions in wsock32. A little code duplication is better than adding entry points.
An even better alternative that would avoid the duplication could be to have the 16-bit functions implemented in wsock32 instead of ws2_32, but this is probably a lot more work.