On Wed, Mar 5, 2008 at 11:58 AM, Christopher raccoonone@procyongames.com wrote:
resubmitting my patch to resolve a merge conflict with the latest GIT
Christopher Berner
From 47a770102acf010834899489416e92fd4f79ffd1 Mon Sep 17 00:00:00 2001 From: Christopher Berner raccoonone@procyongames.com Date: Wed, 5 Mar 2008 09:28:26 -0800 Subject: [PATCH] make LoadStringW pass conformance tests
dlls/crypt32/oid.c | 3 ++- dlls/hhctrl.ocx/help.c | 4 ++-- dlls/mpr/wnet.c | 3 ++- dlls/user32/resource.c | 14 +++++++++++++- dlls/user32/tests/resource.c | 29 +++++++++++------------------ 5 files changed, 30 insertions(+), 23 deletions(-)
diff --git a/dlls/crypt32/oid.c b/dlls/crypt32/oid.c index 5d17997..edd9732 100644 --- a/dlls/crypt32/oid.c +++ b/dlls/crypt32/oid.c @@ -1402,8 +1402,9 @@ static void init_oid_info(HINSTANCE hinst) } else {
LPWSTR junkpointer; /* third argument cannot be NULL, to receive length of resource from LoadStringW */ int len = LoadStringW(hinst, (UINT_PTR)oidInfoConstructors[i].pwszName,
NULL, 0);
(LPWSTR)&junkpointer, 0);
Why don't you just name the new parameter the same name as the function parameter ('buffer' or some variation)? junkpointer is a terrible variable name.
James Hawkins wrote:
On Wed, Mar 5, 2008 at 11:58 AM, Christopher raccoonone@procyongames.com wrote:
resubmitting my patch to resolve a merge conflict with the latest GIT
Christopher Berner
From 47a770102acf010834899489416e92fd4f79ffd1 Mon Sep 17 00:00:00 2001 From: Christopher Berner raccoonone@procyongames.com Date: Wed, 5 Mar 2008 09:28:26 -0800 Subject: [PATCH] make LoadStringW pass conformance tests
dlls/crypt32/oid.c | 3 ++- dlls/hhctrl.ocx/help.c | 4 ++-- dlls/mpr/wnet.c | 3 ++- dlls/user32/resource.c | 14 +++++++++++++- dlls/user32/tests/resource.c | 29 +++++++++++------------------ 5 files changed, 30 insertions(+), 23 deletions(-)
diff --git a/dlls/crypt32/oid.c b/dlls/crypt32/oid.c index 5d17997..edd9732 100644 --- a/dlls/crypt32/oid.c +++ b/dlls/crypt32/oid.c @@ -1402,8 +1402,9 @@ static void init_oid_info(HINSTANCE hinst) } else {
LPWSTR junkpointer; /* third argument cannot be NULL, to receive length of resource from LoadStringW */ int len = LoadStringW(hinst, (UINT_PTR)oidInfoConstructors[i].pwszName,
NULL, 0);
(LPWSTR)&junkpointer, 0);
Why don't you just name the new parameter the same name as the function parameter ('buffer' or some variation)? junkpointer is a terrible variable name.
sure, I will change it.
Christopher raccoonone@procyongames.com writes:
James Hawkins wrote:
Why don't you just name the new parameter the same name as the function parameter ('buffer' or some variation)? junkpointer is a terrible variable name.
sure, I will change it.
Actually what you should do is take advantage of the fact that the pointer is returned to simplify the code and avoid a second LoadStringW call.
Alexandre Julliard wrote:
Christopher raccoonone@procyongames.com writes:
James Hawkins wrote:
Why don't you just name the new parameter the same name as the function parameter ('buffer' or some variation)? junkpointer is a terrible variable name.
sure, I will change it.
Actually what you should do is take advantage of the fact that the pointer is returned to simplify the code and avoid a second LoadStringW call.
Is there more work I need to do on this patch? I noticed that the new copy that I sent in, with the corrections that everyone suggested, still hasn't been accepted.
Christopher Berner