Would it make sense to rename shader_select()/vp_enable()/fp_enable() to something like shader_apply_draw_state()/vp_apply_draw_state()/fp_apply_draw_state(), along the lines of wined3d_context_vk_apply_draw_state()?
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/5053#note_60593
This is in preparation for the mach thread id rework, which requires 64 bit there (and incidentally also stops truncating the FreeBSD one).
There wasn't any direct usage of `__int64` in the sever protocol before, so I added a new typedef and a new `dump_int64()` function (not sure if needed per se though).
--
v6: ntdll: Remove unneeded FreeBSD codepath in get_unix_tid().
server, ntdll: Use 64 bit for unix thread id.
https://gitlab.winehq.org/wine/wine/-/merge_requests/5047
This is in preparation for the mach thread id rework, which requires 64 bit there (and incidentally also stops truncating the FreeBSD one).
There wasn't any direct usage of `__int64` in the sever protocol before, so I added a new typedef and a new `dump_int64()` function (not sure if needed per se though).
--
v5: ntdll: Remove unneeded FreeBSD codepath in get_unix_tid().
server, ntdll: Use 64 bit for unix thread id.
https://gitlab.winehq.org/wine/wine/-/merge_requests/5047
The state table, as may have been described elsewhere, is not very friendly to
modern CPUs (due to its indirect calls). Additionally, interdependencies between
states are often more obscure (or at least harder to account for) than they
might be with a linear function.
Hence, we'd like to transform the table into a linear function, with "dirty"
state guarding explicitly spelled out. For the FFP tables, the approach I've
taken to achieve this is to gradually move states out of the table and into the
existing vp_enable() and fp_enable() functions, eventually making those
functions the aforementioned single linear functions.
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/5053