Giovanni Mascellani (@giomasce) commented about libs/vkd3d-shader/hlsl_codegen.c:
static void copy_propagation_invalidate_whole_variable(struct copy_propagation_var_def *var_def) {
unsigned int component_count = hlsl_type_component_count(var_def->var->data_type); unsigned i;
TRACE("Invalidate variable %s.\n", var_def->var->name);
- for (i = 0; i < var_def->var->data_type->reg_size; ++i)
- for (i = 0; i < component_count; ++i) var_def->values[i].state = VALUE_STATE_DYNAMICALLY_WRITTEN;
}
-static void copy_propagation_set_value(struct copy_propagation_var_def *var_def, unsigned int offset,
unsigned char writemask, struct hlsl_ir_node *node)
+static void copy_propagation_set_value(struct copy_propagation_var_def *var_def, unsigned int comp,
For the future, please do code cleaning stuff (like renaming variables) in dedicated commits, so that the "meaty" commits are easier to read.