Fixes a hang when joining a multiplayer game in Burnout Paradise Remastered. The game expects to find a space in the device name and spins forever trying if it can't.
-- v3: winepulse.drv: Change device description.
From: Paul Gofman pgofman@codeweavers.com
--- dlls/winepulse.drv/pulse.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/dlls/winepulse.drv/pulse.c b/dlls/winepulse.drv/pulse.c index 0ddddb00185..62658fc98e6 100644 --- a/dlls/winepulse.drv/pulse.c +++ b/dlls/winepulse.drv/pulse.c @@ -833,8 +833,9 @@ static NTSTATUS pulse_test_connect(void *args) list_init(&g_phys_speakers); list_init(&g_phys_sources);
- pulse_add_device(&g_phys_speakers, NULL, 0, Speakers, 0, "", "PulseAudio"); - pulse_add_device(&g_phys_sources, NULL, 0, Microphone, 0, "", "PulseAudio"); + /* Burnout Paradise Remastered expects device name to have a space. */ + pulse_add_device(&g_phys_speakers, NULL, 0, Speakers, 0, "", "PulseAudio Output"); + pulse_add_device(&g_phys_sources, NULL, 0, Microphone, 0, "", "PulseAudio Input");
o = pa_context_get_sink_info_list(pulse_ctx, &pulse_phys_speakers_cb, NULL); if (o) {
On Wed Oct 18 18:08:43 2023 +0000, Huw Davies wrote:
I guess I'm persuaded that "PulseAudio Input" and "PulseAudio Output" are better names than what we have (and also happen to have a space ;-), so let's go with out. I do wonder whether we actually want to keep these two. Now that we enumerate all of the devices, we could probably get rid of them.
IIRC @ivyl was looking at something in this direction (to get rid of "PulseAudio" device listed along with real device names) but also IIRC there were some difficulties with that. Arek, if you recall something about that maybe you could comment on it?
On Wed Oct 18 18:08:43 2023 +0000, Paul Gofman wrote:
IIRC @ivyl was looking at something in this direction (to get rid of "PulseAudio" device listed along with real device names) but also IIRC there were some difficulties with that. Arek, if you recall something about that maybe you could comment on it?
Those "devices" are useful though. They're the only ones moveable in the PA mixer, opaque to the application (like how Linux native applications are in most cases). Obviously the others can't be moveable since the app specifically selects them in such case, so it would be very confusing for the user.
This merge request was approved by Huw Davies.