From: Zebediah Figura zfigura@codeweavers.com
--- dlls/winepulse.drv/mult.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dlls/winepulse.drv/mult.c b/dlls/winepulse.drv/mult.c index 26b5e83c9ca..98d2e8541b0 100644 --- a/dlls/winepulse.drv/mult.c +++ b/dlls/winepulse.drv/mult.c @@ -32,7 +32,7 @@ * These were taken from PulseAudio's sources but adjusted to directly * fit our usage (since we use floats directly) so they should be exact. */ -UINT8 mult_alaw_sample(UINT8 sample, float vol) +UINT8 DECLSPEC_HIDDEN mult_alaw_sample(UINT8 sample, float vol) { static const float decode_to_13bits_float[1 << 8] = { @@ -708,7 +708,7 @@ UINT8 mult_alaw_sample(UINT8 sample, float vol) return encode[(int)(vol * decode_to_13bits_float[sample]) + ARRAY_SIZE(encode) / 2]; }
-UINT8 mult_ulaw_sample(UINT8 sample, float vol) +UINT8 DECLSPEC_HIDDEN mult_ulaw_sample(UINT8 sample, float vol) { static const float decode_to_14bits_float[1 << 8] = {
Perhaps it would make more sense to rename `mult.c` to `mult.h`, make these two functions `static inline` and include `mult.h` in `pulse.c`?