As far as I can tell, ime.h is only included by the x11 keyboard driver and `WM_IMEKEYDOWN` and `WM_IMEKEYUP` are not used there, so this change should only bring the naming convention in line with what is already in winuser and MSDN.
From: Marc-Aurel Zent mzent@codeweavers.com
--- include/ime.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/ime.h b/include/ime.h index 9312e37bc15..4b535d6c72e 100644 --- a/include/ime.h +++ b/include/ime.h @@ -139,8 +139,8 @@ typedef struct tagIMESTRUCT { #define WM_CONVERTRESULT 0x010B #define WM_INTERIM 0x010C
-#define WM_IMEKEYDOWN 0x290 -#define WM_IMEKEYUP 0x291 +#define WM_IME_KEYDOWN 0x290 +#define WM_IME_KEYUP 0x291
typedef struct tagUNDETERMINESTRUCT { DWORD dwSize;
Hi,
It looks like your patch introduced the new failures shown below. Please investigate and fix them before resubmitting your patch. If they are not new, fixing them anyway would help a lot. Otherwise please ask for the known failures list to be updated.
The tests also ran into some preexisting test failures. If you know how to fix them that would be helpful. See the TestBot job for the details:
The full results can be found at: https://testbot.winehq.org/JobDetails.pl?Key=149673
Your paranoid android.
=== debian11b (64 bit WoW report) ===
ddraw: ddraw4.c:3978: Test failed: Expected (0,0)-(1024,768), got (-32000,-32000)-(-31840,-31969). ddraw4.c:4050: Test failed: Expected (0,0)-(640,480), got (-32000,-32000)-(-31840,-31969). ddraw4.c:4075: Test failed: Expected (0,0)-(640,480), got (-32000,-32000)-(-31840,-31969).
Ah, this does double define `WM_IME_KEYDOWN` and `WM_IME_KEYUP` in the x11 driver then... Will try to see if there is a better solution for this