On Tue Oct 31 20:09:06 2023 +0000, Zebediah Figura wrote:
> Thanks, this is looking almost right now, just a few more nitpicks.
> And again sorry about the late review :-/
Yeah, this project is getting way longer than I expected.
With how many watchers BUG-9127 has, I'm surprised there aren't more people floating around asking and/or "asking" everyone to hurry up... but on the other hand, nobody linked this MR in that bug, so they won't know anything's going on until Alexandre closes bugs fixed in 8.20.
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/3938#note_50386
On Tue Oct 31 18:36:05 2023 +0000, Zebediah Figura wrote:
> Since we've implemented "mt", can we check its contents?
but then the tests break on native because that thing gives weird results unless the source pins are connected :<
Fixed, and then fixed the Wine-side code to match. Also fixed a buffer overflow; calling wg_parser_get_stream() before range checking the index probably isn't a particularly brilliant idea.
...it's just completely random which functions need FreeMediaType and which need DeleteMediaType, isn't it? At least it's documented.
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/3938#note_50385
On Tue Oct 31 18:36:04 2023 +0000, Zebediah Figura wrote:
> We can delete this line.
https://learn.microsoft.com/en-us/windows/win32/api/strmif/nf-strmif-iamstr… says that parameter can return non-NULL, so it felt wrong to potentially leak it.
But that same page says this specific filter, and every Windows builtin, always returns NULL, so checking for something that's documented to never happen is also kinda wrong.
Which means I have no particular opinion in either direction. If you do, let's go with that.
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/3938#note_50384
On Tue Oct 31 18:36:03 2023 +0000, Zebediah Figura wrote:
> This can be static now.
> Let's use enum wg_video_format instead of wg_video_format; the latter is
> a typedef of UINT32 and therefore the compiler won't recognize it as an enum.
> I don't particularly like the naming "get_bytes"; that sounds like it's
> retrieving the actual data in some sense. How about
> "wg_format_get_max_size_video_raw()", matching the naming scheme for wg_format_to_caps()?
Yeah, I refactored that one about 38 times while creating this MR, some of which called it from other source files. But yeah, this version doesn't, so let's fix it. (Did anyone try compiling Wine with -Wmissing-declarations? That one throws a warning for nonstatic functions with no preceding prototype, and is perfect for catching things that should be static.)
I have no particular opinion on the name, so sure, we can do that.
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/3938#note_50383