Zebediah Figura (@zfigura) commented about dlls/winegstreamer/quartz_parser.c:
>
> #define ALIGN(n, alignment) (((n) + (alignment) - 1) & ~((alignment) - 1))
>
> +unsigned int wg_format_get_bytes_for_uncompressed(wg_video_format format, unsigned int width, unsigned int height)
This can be static now.
Let's use enum wg_video_format instead of wg_video_format; the latter is a typedef of UINT32 and therefore the compiler won't recognize it as an enum.
I don't particularly like the naming "get_bytes"; that sounds like it's retrieving the actual data in some sense. How about "wg_format_get_max_size_video_raw()", matching the naming scheme for wg_format_to_caps()?
--
https://gitlab.winehq.org/wine/wine/-/merge_requests/3938#note_50375